Accessing Openboxes by ip address on windows

I installed Openboxes on a Windows 10 machine. After a bit of small issues I have it running well.
I can access it on the install machine fine by IP address and localhost. My issue is I cannot get access to it by IP address by any other computer in my network, Mac, using Google Chrome or Safari. I do not want it accessed outside the network just internal but I am not sure what to change in any config files to do this.
Any help would be appreciated.

What error do you get if you try to access it?
Do you have any firewall configurated on the machine, if yes does it allow external access?

Thanks for jumping in @David_Douma.

@JRBjohn There’s nothing specific within OpenBoxes that would prevent you from accessing the web application (by IP address) over a LAN. But we do have a setting that might get in the way if you don’t have it set properly.

You should set the following property in your file to the IP address of the computer that is running OpenBoxes.

grails.serverURL = http://<ip-address>:8080/openboxes

If that doesn’t help, then as @David_Douma mentioned, I would recommend talking to your network administrator to ensure the computers are on the same network and there are no firewall rules preventing traffic to/from any of the computers over certain ports.

If you are your network administrator, we should jump on a call to discuss your setup.


Hello all,
Thanks for getting back to me.
I will give your suggestions a try and let you know how it goes.
I am the network admin and I do not think I have anything that would block same network connections.
The only thing I can think is if I used 8080 for anything else.
I will run through my network and let you know.
Thanks again,
John June

Hello all,
After a bit of testing and fixing my NAT issue I tested again and still not luck.
I disabled windows firewall and boom it is working fine. So it is a windows firewall issue.
I tried to add a new rule but I could not find tomcat listed so I am not sure how to add it to the exception list.
Any help would be appreciated again.
John June

Adding an inbound rule to allow traffic over port 8080 is should be sufficient. There shouldn’t be a need to be specific about the application (Tomcat) that’s on the other end of that.

WOOT!! Got it. Thanks everyone. Now to start adding material and locations and everything.
So excited. Can’t wait to have this setup for everyone in the office to use.
I might need help later getting the hand scanner part to work but that is later.
Thanks again,
John June