Consumption - Location Type

I have a central deposit and I consume some materials, but I need to know in the report where the consumption took place.
My central depot is configured as Location Type Depot and I configured the consumption location as Dispensary.
In version 0.8.11 I was sending it to the place of consumption and at the end it marked it as received, but now in version 0.8.22 I can’t do it.
Am I doing it correctly this way?

Hey @Jeferson_Costa!!

How are you? It’s so nice to hear from you!

There used to be a feature that allowed you to bulk receive multiple shipments, but I don’t remember an auto receive. I’ll take a look at the 0.8.11 code to see if I’m forgetting something.

In the meantime can you explain the steps to reproduce for this issue?

For example remind me what feature in 0.8.11 were you using to transfer stock? The old shipment feature?

In addition, what are you using now? Outbound stock movement?

And, what page were you on that shows the outbound as received then vs now?

And lastly, if possible it would be helpful to see some screenshots showing the actual behavior and an explanation of what you were expecting.

A lot has changed between those two versions so it’s possible that we “fixed” something and caused the behavior you’re seeing.


All very well.

Exactly, I used bulk receive multiple shipments.

I use “Create Outbound Movement” to send a product for consumption (Location Dispensary).

After all, is this way of consuming a product correct? I was using it this way because I needed to know where the consumption actually took place.

Thank you for your beautiful work.

The Receive button highlighted in your screenshot is for receiving an inbound stock movement. In other words, that button would be available to you if you were logged into the destination. It’s unintuitive and confusing that this button is displayed for the outbound stock movement context (i.e. when you’re logged into the origin), but this is expected behavior.

There’s no longer a Mark as Received feature that works the way you’re expecting, but it’s something that I’ll discuss with the team to see if we can make it work. @knagel Thoughts?

Another option (and something I built in a separate fork for another project) was to configure the destination as “auto receive” so that all stock movements that were sent to that location would be automatically marked as received. I am planning to migrate these changes back to the core in the near future, but I don’t have a timeline yet.

There are two other ways we can handle this without making any code changes.

  1. You can set up these consumption locations with the “Manage Inventory” supported activity and then log into them to receive the stock movements manually. This takes a bit more overheard and probably isn’t worth your time, but let me know if that’s a workable solution for the time being.

  2. You can also go into the old shipment feature and mark the shipment as received (or just add a Received event to the shipment).

Option 2 is probably the easiest solution, but might not be available much longer as I’m planning on removing the old shipment and requisition pages in one of the next releases (i.e. 0.9.0 or 0.9.1).


Both solutions are interesting. I’ve already tested it and it works perfectly.
A trigger for automatic receipt in “Dispensary” type locations would be very interesting.
Thank you for your time in helping me.