First run on WSL2/Ubuntu 22.04 LTS

First off, let me say that I am grateful for the development team and the quick responses I’ve seen for others’ questions in the forum. I have been playing with the software on a droplet for about four months and finally decided to try my hand at getting it up on a local development machine.

After a week of reading, applying changes, moving files, and generally enjoying the suck, I got everything “fixed” on Friday and fired up Tomcat. OpenBoxes started doing its magic. I left for a long weekend, came in this morning, and found my terminal screen (with tail -f catalina.out, of course) at a stop, somewhere around 2 a.m. on Saturday. I stopped Tomcat and restarted. That was at about 7 AM Eastern. I came back to my desk from my morning rounds and found the following lines on my terminal:

2022-12-20 07:35:16,341 [DefaultPluginScheduler_Worker-3] INFO  data.DataService  - Updated 0 rows in 2 ms
2022-12-20 07:35:16,344 [DefaultPluginScheduler_Worker-3] INFO  jobs.RefreshStockoutDataJob  - Refreshed stockout data in 1775 ms
2022-12-20 07:35:16,398 [DefaultPluginScheduler_Worker-4] INFO  data.DataService  - Updated 0 rows in 262 ms
2022-12-20 07:35:16,423 [DefaultPluginScheduler_Worker-4] INFO  data.DataService  - Executing statement DROP TABLE IF EXISTS order_summary_mv_temp;
2022-12-20 07:35:16,423 [DefaultPluginScheduler_Worker-5] INFO  data.DataService  - Updated 0 rows in 228 ms
2022-12-20 07:35:16,428 [DefaultPluginScheduler_Worker-5] INFO  jobs.RefreshDemandDataJob  - Finished refreshing demand data in 1785 ms
2022-12-20 07:35:16,438 [DefaultPluginScheduler_Worker-4] INFO  data.DataService  - Updated 0 rows in 14 ms
2022-12-20 07:35:16,439 [DefaultPluginScheduler_Worker-4] INFO  jobs.RefreshOrderSummaryJob  - Finished refreshing order summary in 1838 ms
2022-12-20 07:35:16,679 [ForkJoinPool-1-worker-1] INFO  inventory.ProductAvailabilityService  - Refreshing product availability location (Main Warehouse), forceRefresh (true) ...
2022-12-20 07:35:17,366 [ForkJoinPool-1-worker-1] INFO  inventory.ProductAvailabilityService  - Saving product availability for product=null, location=Main Warehouse
2022-12-20 07:35:17,534 [ForkJoinPool-1-worker-1] INFO  inventory.ProductAvailabilityService  - Saved 0 records for location Main Warehouse in 168ms
2022-12-20 07:35:17,534 [ForkJoinPool-1-worker-1] INFO  inventory.ProductAvailabilityService  - Refreshed  0 product availability records for location (Main Warehouse) in 849ms
2022-12-20 07:35:17,539 [DefaultPluginScheduler_Worker-6] INFO  inventory.ProductAvailabilityService  - Refreshed product availability in 2521ms
2022-12-20 07:35:17,543 [DefaultPluginScheduler_Worker-6] INFO  jobs.RefreshProductAvailabilityJob  - Finished refreshing product availability data in 2812 ms

I have tried to go to my Tomcat installation’s administration page, both the root, the manager application, and OpenBoxes itself - all I get is a spinning icon.
So - for those of you in the know - do I just need to wait for OpenBoxes to do the magic…or do I have another issue to run down?

Any answers that y’all can give would be much appreciated.


Thanks, Jeremiah

So your log is showing a normal, healthy Tomcat instance running OpenBoxes. So my question would be … how are you trying to access OpenBoxes?



I’ve tried calling https://localhost:8080, https:localhost:8080/openboxes, and Did I miss something somewhere?


I think I might have it - I’m reinstalling the .WAR file with a fresh database right now.
Windows Firewall might not have been playing nice with Tomcat :slight_smile: I will let you know in the morning whether my adjustments were successful or not.


I was just typing “Try to use http://localhost:8080/openboxes or check the firewall”. Good luck.

Hi there. If you could provide the step-by-step instructions on this, it would be much appreciated.

@Blessedangelica What step-by-step instructions are you looking for? Ubuntu 22.04? Specifically WLS2?

@jrcook416 I just noticed something I hadn’t noticed before

finally decided to try my hand at getting it up on a local development machine.

Are you trying to actually do some development? Or do you just want to have a local machine to test on? If you’re looking for how to start developing those would require a different set of instructions.

I’d be happy to help with that setup and any questions you might have along the way.

Oh, I did not realize that this is for devs. Haha. But I am seeing good things installing Openboxes using Virtualbox7 and Ubuntu 18.04.6 LTS. Looking at development logs at the moment.

@Blessedangelica Yes, the instructions from the README (linked above) are for developers. You can also use those instructions to test the software locally, but I would not recommend using those if you are trying to deploy a test/production environment that could be used by other users.

The instructions in the docs (linked below) are for users who are trying to deploy the application for a test/production environment.