Moving 'on hold' back

Hi there,

I have a problem with a feature. It seems that everyone can move items into a holding bin but only SuperUsers can move them back?

If I login as a test user with Manager rights on the depot I can move items into a holding bin from Create Stock Tranfer. But if I want to move them back from the same option the item is not pick-able (that makes sense of course). So I went over to the product stock card and tried to move the product with the dropdown option, however then I get the error that I don’t have enough rights? How can a depot Manager move items back from ‘on hold’ to another bin?


Interesting. I am not familiar with that access restriction, but will take a look when I get a chance. My hunch is that the entire transfer stock feature is not available to Managers, not just move items back from the On Hold bin.

In the meantime, you should be able to use the new Stock Transfer feature.

Actually rethinking that I’m sure if the restriction was added to the old transfer stock feature it probably exists in the new feature as well. I’ll look into that as well but there might not be a quick fix as I assume this restriction is expected behavior.

Okay, because I loved the option to put stock on hold. But if that means only a SuperUser can transfer stock back that option is then useless. Because every Manager should be able to move stock around in their depot (my opinion).

Maybe other question that resolves my problem for a little bit: The Hold feature comes with a colored bar so you can see very fast that it’s on hold. Is it possible to give other Bin Locations different colors?

That’s correct. You can’t move stock that is on hold.

One of our developers researched the issue and came to the following conclusions

  1. Managers can use the new stock transfer feature and make a transfer from hold bin.
  2. Managers can not make the old stock transfer feature (it is already forbidden/access denied for managers to complete old stock transfer)
  3. If someone managed to transfer as a manager, then I’d say it was a weird bug, but I cannot reproduce it locally (i have properly displayed access denied message)

For (1) let me know if you need help figuring out how to use the new stock transfer feature to transfer between a hold and non-hold bin location.

For (2) and (3) we’re working on making the ACL rules configurable from the runtime configuration (openboxes-config.groovy) so hopefully we’ll able to make the old stock transfer work for managers as well. In the

Thanks for the follow-up. Option 1, using the new ‘Create Stock Tranfer’ option is not working. If an item is in the holding bin you can’t select the item with ‘Create Stock Transfer’ the selection box is grayed out and not select-able.

So the problem is still the same, nobody can move an item from Hold back into a normal bin with the Create Stock Transfer thing.

Hi @David_Douma, The reason why you cannot move it out of this bin is that the ‘Quantity Available to transfer’ is 0. That’s why the option is grayed out/disabled.
However, now I see the issue with it. It is that after transferring something to the hold bin it will set automatically ‘quantity available to promise’ to 0 (which is expected, at the moment, Edit: this should not be the issue, since we base tha quantity available to transfer on the quantity on hand minus the quantity allocated). The workaround for it now would be to take off the ‘hold stock’ activity code from the bin, wait for product availability to refresh on it, transfer the stock, and then reapply the ‘hold stock’ activity code on the given bin. I guess the warning or information about transferring something to the hold bin would be useful.

@David_Douma another thing that might be the real case here is that the quantity available to transfer is the quantity on hand minus the quantity picked (allocated). Perhaps it is already allocated in some other stock movement or transfer, hence the quantity available to transfer is 0 and the line is disabled.

@Artur thanks for you reply.

I really don’t know how to fix this. For example:

I have a product called ‘testproduct4’, currently in the BIN ‘Uitleen’.

I move it to the hold bin, so on the stockcard it says ‘hold’. On Hand is 1 and available is 0.

If I then want to move it back the same way it is grayed out.

So how do I get the item back into a normal BIN? I think it has something to do with available = 0. But that is normal because technically it’s no longer available because it’s on HOLD.

Any follow-up on this? :slight_smile:

@David_Douma I cannot reproduce the issue on the new stock transfer feature. I am able to make a stock transfer from the hold bin as a manager user.

Are you sure this quantity for that product in that bin was not already allocated in some other transfer or stock movement? I this is not the case, then I think you have 2 options that require a superuser:

  1. Use an old stock transfer as a superuser.
  2. Temporarily remove the ‘HOLD_STOCK’ activity code for that bin, make a stock transfer and then reapply the ‘HOLD_STOCK’ activity code on that bin (keep in mind to wait a moment for the product availability to refresh) - however, this option might still not help if this quantity is already allocated somewhere else.

@Artur thanks for your time and respond.

I did the following to be sure it’s not something I do wrong:

  1. Record a new stock for Testproduct3

So 10 items are available

  1. Create a stock tranfer with: Inventory → Create Stock Transfer.

So I transferred 10 items to the Hold.

  1. Then I wanted to transfer the same item back into a normal Bin. Again with: Inventory → Create Stock Transfer. But this time the select box is not select able but grayed out.

I think it has something to do with the ‘available to transfer’ because when I move it to the bin it drops to 0.

These are my settings for the Bin / Location:


@Artur any news if it’s a fault in my end or… ? :slight_smile:

Hey David

Sorry for the delay. I was off at the end of last week.

I just tested the feature again on our development server and it works for me as expected.

I also recorded a video demonstrating the feature as a user with role Manager.

By the way that is not an recommendation to use the “snapshot” version but rather I wanted you to know that it seems to be working fine and perhaps you need to wait until the next release 0.8.18 if it’s still not working in 0.8.17.

@jmiranda thanks for the follow-up.

It seems it has something to do with Quantity Available to Transfer. In your video after you transfer it into the hold bin, your Quantity Available to Transfer says not ‘0’ like it does at my end. Do you have a screenshot from the settings in Location → Bin Location → Hold & Location type Hold? Maybe it has something to do with the settings.


See my settings:


Can you take a screenshot of any page and include the footer? I want to see what version / commit your system is running.

Also, the v0.8.18 release has been officially published.