Opening port 8080 on firewall

I’m currently trying to deploy Openboxes 0.8.16 from Release Release 0.8.16 · openboxes/openboxes · GitHub on my Ubuntu 18.04 Google VM (e2-standard-2, 2vCPUs, 8GB memory) but it always hangs for several hours at the same spot during the database migration (line 2374 in catalina.out).

2021-08-06 02:06:30,069 [DefaultPluginScheduler_Worker-3] INFO jobs.RefreshProductAvailabilityJob - Finished refreshing product availability data in 2061 ms

I’ve followed the instructions to the tee on the docs and looked at common chokepoints for errors on the troubleshooting section and the discourse forums for Openboxes.

I’ve tried now with 2 fresh VM instances with the same hanging problem. I’ve also tried to reinitialize the openboxes database and it hangs in the same spot. I’ve tried to remove the databasechangeloglock record in the database with no success.

I can confirm that I have a tomcat group and user set up with cat /etc/passwd | grep tomcat returning tomcat:x:1004:1005::/opt/tomcat:/bin/false

Some errors I’ve noticed in catalina.out

  1. Line 65, 1795, 1899 in my catalina.out says that my is not found, but it is indeed in my /opt/tomcat/.grails directory with -rw-r--r-- permissions. The repeat entries are from me restarting the tomcat services and trying to deploy it again.

  2. Line 860 has liquibase.exception.JDBCException: Error executing SQL CREATE OR REPLACE VIEW openboxes.product_demand AS SELECT and I’ve tried to increase the memory for tomcat from 128m to 512m in /etc/systemd/system/tomcat.service

catalina,out pastebin link: Openboxes catalina.out stuck -

Let me know if I can provide any more information. Thank you!!!

After contacting Openboxes support it was resolved that my deployment was functional and that the problem was my firewall on my Google Cloud Compute instance was blocking access to port 8080.

After opening port 8080 (following instructions found here: How to open a specific port such as 9090 in Google Compute Engine - Stack Overflow) everything was smooth :slight_smile:

Thanks for posting this, @mico!

1 Like