How to transfer stock between depots?

Hi, rather stuck here. I’m certain I used to be able to do this, but I’m now unable to transfer stock from a bin location within a depot to another bin location in another depot.

The only options are the current depot and the bin locations under it.

Any idea? Very useful to have a quick way to transfer items between depots.

I’ll check the code to see if that dropdown is driven by a supported activity.

Sorry you cannot unselect the Destination depot? And select a different one?

It looks like there was a change in 0.8.22-hotfix1 (released sometime last summer?) that removed external depots from the list of destinations.

OBPIH-5687 Use same product dropdown for both transfer stock and transfer out

  • filter out locations that support MANAGE_INVENTORY and Supplier locations
  • use same product dropdown for stock transfer in modal

Here’s the ticket for transparency.

OBPIH-5687 Disable or fix permissions for transfer out from product dropdown.pdf (576.8 KB)

I will try to resolve this, but need to come up with a good scheme that allows it to be configurable so we don’t break the change made by the aforementioned ticket.


Until that is fixed it seems the only way to transfer to another depot would be to create an outbound stock movement.

In order to transfer the item to the desired bin (once the item has arrived at the destination) you’ll then need to log into the destination location and perform a receipt and/or putaway.

  • one step putaway: receive the item into the bin
  • two step putaway: receive into a receiving location and create a putaway order to transfer to the bin

Apologies for the inconvenience, but we’ll try to get this fixed soon.

I’ve create a new bug ticket for this one.

Hey Justin,
Thanks for looking at this, relieved to know it’s just a bug, makes sense now as before updating from 0.8.20 this functionality worked, it took me a while after updating to notice it had broken however as not something we need to do too often! Thanks for being so responsive, I shall use the mentioned workaround for now and keep an eye on the GitHub issue.